3 ansys18.2和ls-dyna-r11在win10电脑是否兼容?

我之前ansys18.2用的好好的,后来下载了一个ls-dyna-r11后,ansys中的dyna就用不了了,老说“错误此版本(LS-DYNA)不包含在当前许可证密钥中。”我后来重新装了一遍,还是不行,不知道是不是不兼容的问题。attachments-2019-04-0pIS6XVr5cbae5019fb56.PNG

  • 2019-04-20 17:23
  • 353
请先 登录 后评论

2 个回答

XY
擅长:LS-DYNA,AUTODYN

这个是系统环境变量被更改的原因导致的,Ansys中内嵌了LS-DYNA求解器,再次安装独立版本的求解器的话,实际上系统内部有两个求解器,一个是Ansys内嵌的求解器,另一个是你安装的R11求解器,这两个求解器和系统都是兼容的,包括Win10,但是两个求解器间有个问题,就是每次只能使用一个求解器,你用了R11版本的独立求解器,就不能使用Ansys内嵌的求解器,你使用了Ansys内置的求解器,就不能在使用R11版本的独立求解器。

并且这两个求解器还不能在软件界面直接切换,需要修改Windows系统的环境变量,才能切换两个求解器,环境变量的更改如下所示:

使用Ansys求解器,环境变量设置为:

LSTC_LICENSE=ANSYS

使用R11独立版本求解器,环境变量设置为:

LSTC_LICENSE=LOCAL

如果不会设置环境变量的话,请通过控制面板-》系统与安全-》系统-》高级系统设置-》环境变量-》系统变量,找到LSTC_LICENSE,按上述方法更改设置即可。有时系统环境变量的更改会不及时,这是需要重启系统,或重启软件。

请先 登录 后评论
win - 研究生

非常感谢你回答的问题,我想问的是,使用之前要修改环境变量?还是重新编辑一个环境变量是这两个环境变量共同存在?(我试了一下,只能存在一个,不能两个同时存在。)

请先 登录 后评论