2 已安装 visual studio 2008 情况下,再安装 Fortran 还是提示 not find a supported Microsoft Visual Studio

已经安装了 visual studio 2008,再安装 portran 的时候,还出现如图所示的错误提示是怎么回事

attachments-2019-04-Ji6YEWP15cb703a7249d0.png

  • 587
请先 登录 后评论

最佳答案

首先需要确定安装的 Visual Studio 和 Fortran 是否匹配,通常的适配关系如下:

  • 英特尔 Visual Fortran Composer XE 2011(编译器版本 12.0 或 12.1),支持 Visual Studio 版本 2005,2008 和 2010。
  • 英特尔 Visual Fortran Composer XE 2013(编译器版本 13.0 和 13.1),支持 Visual Studio 版本 2008,2010 和 2012。
  • 英特尔 Visual Fortran Composer XE 2013 SP1(编译器版本 14.0),支持 Visual Studio 版本 2008,2010,2012 和 2013。(在 Composer XE 2013 SP1 Update 1 中添加了 VS2013 支持。)
  • Intel Parallel Studio XE 2015(编译器版本 15.0),支持 Visual Studio 版本 2010,2012 和 2013. 此外,Intel Parallel Studio XE 2015 Update 4 增加了对 Visual Studio 2015 的支持。
  • Intel Parallel Studio XE 2016(编译器版本 16.0),支持 Visual Studio 版本 2010,2012,2013 和 2015。
  • Intel Parallel Studio XE 2017(编译器版本 17.0),支持 Visual Studio 版本 2012,2013,2015 和 2017。注意:仅 Visual Studio XE 2017 Update 5 支持 Visual Studio 2017。
  • Intel Parallel Studio XE 2018(编译器版本 18.0),支持 Visual Studio 版本 2013,2015 和 2017。
  • Intel Parallel Studio XE 2019(编译器版本 19.0),支持 Visual Studio 版本 2013,2015 和 2017。

如果安装的版本不存在问题,仍然出现图中所示的现象,请移步:

请先 登录 后评论

其它 1 个回答

ZhiQingG

建议安装 VS2010,VS2008 也许不支持 Intel Fortran10.0

请先 登录 后评论