Mac 上基于 QT5.12 和 Xcode 编译 VTK8.1.1,编译成功后,在 QTdesiginer 中没有 Qvtk 插件的原因

  • 843
请先 登录 后评论

最佳答案

如果编译正确,在 QTDesiginer 中是有 QVTK 插件的, 只是由于不同版本的 QT 编译出来的 QTDesiginer 插件不能通用 ,所以需要相同版本的 QT 编译器编译的插件才可以呗 QDesiginer 识别。

此外,QTCreator 中的 Desiginer 与 QT 版本是脱节的,也就是说,从官网网上下载的安装包,QTCreator 和 QT 编译器起其实不是一个版本 ,所以通过直接打开安装文件夹下的 Desiginer 会发现,其中包含 QVTK 插件,而集成 IDE,QTCreator 中的 Desiginer 因与编译器版本不能,所以无法识别编译的插件。

请先 登录 后评论

其它 0 个回答