Linux 系统发行版 debian 10 下安装 QT5.15 后,无法打开 QtCreator 是什么原因

提示错误信息如下:

This application failed to start because it could not find or load the QT platform plugin "xcb"
in "".
Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.
  • 730
请先 登录 后评论

1 个回答

匿名
擅长:LS-DYNA,AUTODYN

使用 terminal 运行 Qtcreator,寻找无法运行的原因,首先切换到 Qtcreator 安装目录,如:

cd ~/QT/Tools/QtCreator/bin

运行 Qtcreator,提示 QtCreator/lib/QT/plugins/platforms 下缺少 xcd 等库文件。下载链接:libxcb-util.so,或者通过网盘下载: 百度网盘 提取码: rphj。

下载完成后,以 root 权限安装:

dpkg -i ./libxcb-util1_0.4.0-1+b1_amd64.deb

完成后可以正常打开 QtCreaor。

请先 登录 后评论