请教生成 LSDYNA 新求解器时的问题

您好!又来请教您了。下面是我用的版本信息:

vs2008
Intel complier XE2011
LSDYNA_R700_smp_lib

我在生成 LSDYNA 的 EXE 文件时,出现了下图这个问题,想请问您这是因为我的编辑器没有按指定的 10.1 版本,还是因为其他问题呢?

attachments-2020-02-igqrOaai5e50bae253bb0.png

  • 583
请先 登录 后评论

4 个回答

XY - 开发者 @ 学研谷
擅长:LS-DYNA,AUTODYN

这个问题是缺少运行库导致的,有几个方法可以尝试一下:

  • 去网上下载,或者是在自己的电脑中,搜索是否有相应的 libguide.lib 文件;
  • 检查一下你的指导教程,是否有推荐的编译器,采用已经编译没有问题的配置去编译程序;
  • 另外这里有一份关于 libguide.lib 运行库缺失的说明:lib guide.lib

请先 登录 后评论
迷茫梦乡 - 研究生

需要严格按照编译器版本来,VS2008+IVF 10.1

请先 登录 后评论
连三 - 研究生

谢谢!我再找找 10.1 版本的编译器吧

请先 登录 后评论
regrets

需要按照 readme 文件里的开发环境说明,去配置开发环境,严格的按照说明操作。例如文件一开始就以编译环境说明:

Compiler and version:
 1.Intel Fortran:
Intel(R) Fortran Compiler for Intel(R) EM64T-based applications,
Version 10.1 
 2.Microsoft Visual C++:
Microsoft Visual C++ 2008 x64 cross tools

请先 登录 后评论